Virgin Mobile

Moto g6 Play - No Data Connectivity

Enthusiast

Moto g6 Play - No Data Connectivity

I've been having data connectivity issues since June/July. I thought it was a software update or maybe a glitch. I tried the ##7... option, no luck. I did a factory reset on my phone last week, still nothing. I try turning the data off and on, turning the phone off an on, no fix. On occasion, I'll get a minute or two of data connectivity but no more unless I can get on wifi. I'll have everything from full bars on LTE to mostly full bars on 3G to roaming at the same location in the same day. Sometimes the exclamation point shows up on the signal bar icon, sometimes it doesn't. This happens whether I'm at home, at work, visiting out of town, or on the road. My spouse has a different phone, same service, and has no problems. It's definitely with the phone. I've had the phone for just over a year and it looks like I'll need to replace it. Might replace services too, it's not worth paying $35-$45/month to only be able to make phone calls and otherwise it's a brick unless it's on wifi. 

6 REPLIES 6

Re: Moto g6 Play - No Data Connectivity

Hmm – that doesn’t sound right. Let’s take a closer look! Can you please send me a private message with your current address, phone number and PIN?

To send a private message just click on the picture of any Boost Mobile agent and, in the next screen, click "send this user a private message". 

Heavy Hitter

Re: Moto g6 Play - No Data Connectivity

I have the same device with the same problem and it also started about a week ago for me too. It looks like I'm being throttled. It takes me 10-15min to download a 7mb file. I've tried factory resetting, resetting my cell networks, and reflashing my stock firmware. Nothing fixes it. I thought it was fixed after Virgin Mobile refreshed my network, but it went back to being horribly slow less than 8hrs later. I'd like to know what's going on with this. I'm switching to T-Mobile if this isn't fixed by Monday. I'm not getting what I paid for.
Highlighted
Agent

Re: Moto g6 Play - No Data Connectivity

We're sorry to hear that, @Modhatter. Please send us a private message with your current address to verify the service in your area.

Heavy Hitter

Re: Moto g6 Play - No Data Connectivity

@Annie1424 

 

I sent you a private message.

Agent

Re: Moto g6 Play - No Data Connectivity

Thank you. We have addressed your private message. Thank you. Victor21

Heavy Hitter

Re: Moto g6 Play - No Data Connectivity

I had to endure horribly slow "hi speed" data for almost 3 weeks and they didn't fix it until I had used 85% of my data cap. Now I'm throttled so bad that it took 6min to load this page. That is absolutely insane and completely unacceptable. Your company did nothing to actually help until what I paid for was already gone. Your company does this every time there's a data issue. "Reset this, lets check coverage maps, okay everything looks good on our end." Same story every time and nothing gets fixed until you've raped me of my hard earned dollars. How about this; get with the techs running your servers and tell them to stop throttling every **bleep** customer you have? What is it going to take for Virgin mobile to fix this on going issue? A lawsuit? The better business bureau? What in the hell is wrong with your company? And who's going to give me my $35 back? Should I go to small claims court? I'm so tired of this runaround.