Virgin Mobile

Activate button on the site doesn't do anything.

Agent

Re: Activate button on the site doesn't do anything.

Hey @Dad We're sorry to hear you're having issues with the activation. We'll be more than happy to assist you! Would you please be so kind to send us a Private Message, so we can further assist you?

 

Note: For you to send a me a Private Message only need to click on my username, which will take to my profile, once you're there on the right side of the screen you will see the option to send me a Message.

 

~JoyP.

Enthusiast

Re: Activate button on the site doesn't do anything.

I have the exact same problem, button does nothing, trying to register an iPhone 6S I bought from the Virgin Mobile website.

Whiz Kid

Re: Activate button on the site doesn't do anything.

How is this still an issue more than six months later?

 

I'm having the exact same issue where I get all the way through the activation proccess only to find that the "activate" button doesn't work.

 

If there's still help available, I'd really appreciate some.

Agent

Re: Activate button on the site doesn't do anything.

Hi there Timsa. Actually, it all depends on whether you are a current customer or not. There are different steps depending on some factors. If you are an existing customer and activating a new Virgin Mobile phone, follow this link; https://www.virginmobileusa.com/login then from your landing page, look to the right for the "I want to.... " menu. There click on Swap My Device and follow the prompts. On the other hand, If you are a new customer and want to activate a new Virgin phone, then use this link; https://activate.virginmobileusa.com/#/your-device and also follow the steps. Finally, if you are a new customer and bringing your own device (BYOD), then follow this link as well; https://www.virginmobileusa.com/plans/bring-your-device.html Hope this more clear for you and if you need assistance just let us know. 

Whiz Kid

Re: Activate button on the site doesn't do anything.

I go to activate an iphone while I am logged in and get to the plan page.  Nothing loads (on any browser) and if I go back it just locks up and never loads again.  I am sitting here trying to swap phones and am unable and am getting very fed up. 

Agent

Re: Activate button on the site doesn't do anything.

Hi there, camarox. Thanks for contacting us. We're sorry for the inconvenience with the phone swap. 

 

We'll be happy to help. Please send us a private message the following: 

 

- phone number and PIN
- serial number (MEID/DEC or IMEI)
- serial number for SIM card (if available, ICCID)
 

Whiz Kid

Re: Activate button on the site doesn't do anything.

I'm having the same problem.

Re: Activate button on the site doesn't do anything.

So sorry about the trouble! Can you please send us a private message with the details, so we can work through this? 

Enthusiast

Re: Activate button on the site doesn't do anything.

I'm having the same issue. It's very frustrating.

Agent

Re: Activate button on the site doesn't do anything.

So sorry to hear about this experience, Person227. We want to help! We value your privacy and security. Due to the nature of your concern, we would like to authenticate your account, but for us to do this in a secure way we need to take this to a private channel where we can discuss private account information. Please send us a private message along with your phone number, the PIN and a brief description of your request. To send a private message, click on any of the social care agents user names and select the option send this user a private messages.